This post has been closed and is not open for comments or answers.

File operations "Copy" won't delete prior transactions

I have Quicken Rental Property manager 2011.
I've validated my file.
When I perform "Year end Copy" or "Copy". Quicken will NOT delete prior transactions before the date I set in the dialogue box.
There are too many accounts and transactions to delete manually.
My file is 22Mb and slowing down.
Please help.
Dave
    Year End Copy ONLY removes non-investment transactions which have been reconciled and are not connected to an unreconciled transaction in any way (that includes via a transfer or a split).

    I wouldn't do a YEC and never have and my file is 33 MB (no attachments) on a 6+ year old Dell with single core cpu, so it is no spring chicken, and it runs just fine.  

    I'd validate a copy of your data file to see if anything there is causing the slow down.

    Trust me, in the not so distant future, you will have a need for all your data to be in one file and you are going to slap yourself on the forehead and think, why did I do that.
    • Twenty two mb is a small file; it's size has virtually nothing to do with any slowing down you're experiencing.  I have a file 3 times as large as yours and I have no slowing ... on an old, slow pc, running Q2011 RPM R8 US.

      And the data most likely to be involved in slowing Quicken down (investment data) isn't deleted when doing a Year End Copy anyway.
    • Thanks for the discussion.
      I have my Quicken data set for a 3 year period, going back to when I was using Managing Your Money.  Don't want 5 years of transactions.
      But..
      If "Year End Copy", does NOT delete prior transactions, why, in "Year end copy",  is there a checkbox saying, "I only want transactions in my current data file starting with this date"

      Quicken USED TO delete prior transactions, why is it broken now?
    I suggest you reread our comments; we did not say Year End Copy does not delete [any] prior transactions.

    Year End Copy deletes the transactions it's designed to delete.

    [Click the small yellow button with the question mark in it when you have the Year End Copy dialog open, to see what Quicken will delete when you do a Year End Copy. Make sure you open all the "+" items in the Help dialog.]
    • Silly me.
         It says it only removes "reconciled" transactions.
      Thanks for your comments and help.
    • I had the problem with some accounts showing transactions prior to the selected start date, until I realized that there were accounts where I hadn't actually done a reconciliation (e.g. one for a car loan being paid down.)  However, the problem occurred even with accounts for which all transactions were reconciled.  As soon as I unchecked the "Include All Prior Uncleared Transactions" box it made the copy with transactions only for the date range specified.  So, I'm not sure why some accounts didn't copy correctly with the box checked, but you might try what I did and see if you get the results you want.
    • Thank you SNRS!  That did it!
      Unchecking the box "Include All Prior Uncleared Transactions" removed the transactions I didn't want.
      Issue solved for me.