This post has been closed and is not open for comments or answers.

Can't register Quicken 2014

I cannot register Quicken 2014 on Windows XP. 

The error message I get is "Unknown error. Please try to log on later." 

Spent an hour with Quick tech support in chat, have installed the mondo update, and the update today.  Unchecked TLS 1.0 in IE (though Firefox is my browser).  Tried to register in safe mode - Quicken goes away completely. 

I am stymied and frustrated.  I've been a Quicken user for several years and this is the first real problem I've had.  Any help would be appreciated!
  • I've also disabled the firewall and the virus checker, which didn't work either.
  • I have the same problem. I'm running xp with sp3. Did chats 2 different times and phone help once. Tried everything imaginable. Then they wanted me to send log files, which I did.   I think the software doesn't work with xp even though they advertise that it will. I hesitate to try it on windows 7 though. I don't need 2 machines screwed up at the same time.
  • .
  • I am running Win 8.1 and i have never gotten the new version to work that i bought and paid for and that Quicken has my money for.  I had to reinstall my 2013 version and I am a very unhappy LOYAL Quicken customer.
It's not TLS 1.0, it's TLS 1.2 for systems that have IE 10 installed on them. You don't advise if you also Reset Defaults in the Internet Options > Advanced Tab, but that should be done in addition to Disable TLS 1.2 - source: http://quicken.intuit.com/support/help/connectivity-troubleshooting/GEN82610.html

Safemode is insufficient - you would need to use Safemode with Networking to have internet access necessary to register the program.

It may have nothing to do with firewall, but could be an aggressive anti-spam/anti-malware filter, cached browser pages, incorrect or stringent Internet Options settings, or even a filtering ISP that prevents certain levels of access (much the same as Parental Controls).

If you're attempting to use an existing Quicken.com user ID, try using the Create New to see if you get better results.

Chat Support would be insufficient for trying to resolve this, as many troubleshooting steps can require you to either reboot your computer or restart it in a different start up mode. Phone Support would be your best assistance.