This post has been closed and is not open for comments or answers.
Quicken Community Home Page

Quicken 2014 Slow to Respond Flashing Hourglass With Each Entry

Upon pressing the enter key for each transaction, the icon with the hourglass and pointer flash for several seconds before the entry is completed. I am running Quicken 2014 on a newer Windows 8 machine. This is not a computer speed issue for the computer is definitely powerful enough for these simple tasks.

Anyone know of a good alternative software to use for I am not happy.
    I solved this problem by changing the default "Tab" to "Bills" versus "Home".  It seems apparently your default tab tries to refresh after any change in any particular register you might happen to be working in.  If you have a big file and a lot of graphs, etc on the Home tab this can take a while given the way Quicken has apparently coded their background (or in this case lack of good background processes in the software).  I'm guessing the "Bills" tab does not require as much (if any) refresh effort after a change is made in a register, therefore the spinning mouse pointer delay goes a way.  At least it did for me. (I am running 2013 with about a 100MB file, but I bought and tested 2014 and the above worked as well.  I'm just waiting for a few more updates to 2014 before using daily).  Regardless, at the end of the day the problem seem to be the result of a sub optimal implementation of refreshing the tabs after a registry update.
    • Where do I change the default tab from Home to Bills?
    • I was quite bothered by the long refresh time in Quicken 2013 and 2014, and changing the default off of Home had a dramatic change. Thanks!
    • How do I take the default off of Home?
    • When first opening Quicken, there is a bill tab. Move the cursor to it and right click. It should give an option to start on bill tab.
    • Thank you for the information, tried it and didn't work!!  Any other suggestions or should I just give myself 30 extra minuted to reconcile an account.
    • It does not remove the delay... Merely lessens it.  Stinks, huh?
    I am running Windows 7, on a high end gaming PC, 10,000 rpm drive and 16gb of ram.  This is the slowest POS of an application that I have ever used (Quicken 2014 H/B).  I have nothing but constant hour glasses blinking and complete slowness, no matter what I try.

    This software program needs some major optimization.  What I am doing now is trying to clean up years of data and only keeping 1 to 2 years worth.  Hopefully this helps.

    What I don't understand is that we are already in the year after Obama 2014, and we don't have a fully web based or web enabled version of Quicken.  Why do we still need to install software locally?

    /sigh - an upset user about the slowness.
      If you upgraded to Windows 8.1, Quicken 2014 is not ready for it. I uninstalled Windows 8.1 and Quicken 2014 works fine. I found that other application also were not ready for Windows 8.1.
        Some people have this problem and some don't.
        You could try here:

        http://quicken.intuit.com/support/help/installing/using-qcleanui-to-uninstall-quicken/GEN82227.html

        Try running the above procedure in Safe Mode, then reboot and reinstall Quicken.

        Also, some have reported that snapshots, and/or popup registers could be the culprit.
        Try File.Save As: and remove any snapshots you have and see if that changes things.

        I do see Quicken eventually get sluggish if it has been running a while. I restart it and all is normal again.
        • Thank you for the attempt at solving my issue. I followed the steps provided and still have to wait about ten seconds after each register entry for every account.
        • Have the same problems as mstringer and the same result from following the procedure - no change.  Still must wait for several seconds after pressing "Enter" for the transaction to process.  Just upgraded from 2011 and wishing I had not done so.
        • If you are using "Catalyst" AMD drivers,the new ones cause conflicts.  perhaps your problem lies there.
        • As a possible fix to the slow entry, try enabling mouse pointer trails.  Control Panel > Mouse > Pointer Options.  Check the box Display pointer trails and set to short.
        • Having the same problem. This is ridiculous...went from 2012 to 2014.